Bosch Building Technologies

    Showing results for 
    Search instead for 
    Did you mean: 

    VG4 AutoDome MPEG4 camera: recording doesn’t work & Bosch logo is displayed in cameo

    Possible causes and solution(s)


    Project set-up:

    • VG4 Autodome MPEG cameras with FW 4.10
    • VRM 3.83
    • DSA E2800 storage

    Note: these MPEG4 cameras are EoL and EoS for a long time now and the Central Technical Support team assistance is done on best effort.


    • Causes

    VG4 AutoDome camera: recording doesn’t work & Bosch logo is displayed in cameo

    Adding the VG4 Autodome MPEG cameras directly to the VRM is not possible because of the firmware version (as per release letter, minimum firmware is 4.15)

    “VRM 3.82 itself is backward compatible with firmware versions 4.15 or higher.”


    • Solution

    We suggested to add the cameras through VSG by using Configuration Manager

    • But make sure there is no recording enabled on the camera itself:
    1_VG4 AutoDome MPEG4 camera-  recording does not work -  Bosch logo is displayed in cameo.png


    • But only a recording running on the VSG instances:

    2_VG4 AutoDome MPEG4 camera-  recording does not work -  Bosch logo is displayed in cameo.png


    Now the camera will be streaming to the VSG and the VSG will take care that that stream will be recorded via the VRM.

    If cameras still don't have image in playback mode but the recordings are taking place, or when you are changing from live view to playback: the recording on the camera stops and the “video lost” message occurs in OP client, then continue with the following steps:

    • try to factory reset the complete camera first (by press and hold the button on the camera)
    • reinstall VSG/VRM on the machine (use the latest build available on the DLS)
    • Then try to add camera back to the VSG.


    By changing Set Recording Quality – Stream Quality Settings to 2/3 D1, the VG4 IP camera will be in recording mode.

    It might happen that by changing to 2 CIF or 4 CIF/D1, the recording will not work anymore, and it will show only the Bosch logo in the cameo. This happens because the camera is not sending I-frames to the VSG. You have to set the camera manually to send I-frames.

    However, if you want to use the maximum resolution possible with the VG4 camera and fix the Bosch logo described above, please follow the steps below.

    Note: If you want to do these changes via Configuration Manager, it will not work well for this old firmware. Therefore, for this old firmware you should use the webpage of the camera.


    • Open the settings in the webpage
    • Go to 'Advanced mode'
    • Go to 'Encoder'
    • Go to 'Encoder profile'
    • Choose in the 'Profile configuration' the profile of choice (standard is the 4CIF profile 3)
    • Click on 'Details'
    • And change the 'I-frame distance' to 1
    • Click on 'set' in that pane

    Now you will see that the message in the CM will go from 'No I-frames' to 'Streaming'


    Version history
    Last update:
    ‎08-25-2022 09:18 AM
    Updated by: